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Adobe® Dreamweaver CS6 Course 

Adobe Dreamweaver CS6 software offers a comprehensive integrated environment in which to design, develop, 

test, and deploy websites and applications of all flavors—spanning the gamut from the simplest, static HTML 

page to complete sites built upon complex dynamic application frameworks. Dreamweaver CS6 streamlines 

both front-end and back-end development tasks with ease. 

With a set of integrated tools available directly in the authoring environment, Dreamweaver CS6 increases your 

productivity and virtually eliminates the need for external third-party browser-based tools. Creative 

professionals can jump-start the design process with updated CSS starter layouts and leverage enhanced CSS 

features for increased control and creative flexibility. Developers benefit from interacting directly with their 

database-driven applications and Ajax interface elements, including testing individual states of a page or 

application throughout the development process. With many compelling new features, Dreamweaver once again 

raises the bar on productivity and efficiency for web designers and developers alike. 

 

With Dreamweaver CS6, you can: 

 Work with the most popular content management systems. Enjoy authoring and testing support for 

third-party PHP-based content management systems like WordPress, Joomla, and Drupal. The 

Dynamically Related Files feature provides direct access to a page’s dependent files, even for complex 

database-driven pages. Live View and enhanced Live Code offer accurate previews of even the most 

advanced dynamic applications. Use Live View Navigation to follow links to reach different application 

states, as well as view pages already on a live server, without leaving Dreamweaver CS6. 
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 Visualize and inspect CSS structure. Design and develop websites with more effective CSS inspection 

tools. With the expanded and more powerful Live View, visually display and interact with the CSS box 

model with no separate browser-based utilities required. Quickly and easily disable and re-enable CSS 

properties directly in the CSS Styles panel for simplified testing.  

 Help ensure cross-browser compatibility. Preview dynamic web pages and local content with multiple 

viewing, diagnostic, and comparison tools. From Dreamweaver, launch Adobe BrowserLab, a new 

Adobe CS Live online service, to preview your web content in multiple browsers and operating systems. 

Navigate to an application state, such as a shopping cart, or freeze JavaScript-generated interface 

elements in Dreamweaver CS6 and preview these states in BrowserLab. 

Who uses Adobe Dreamweaver? 

Professional web designers have made Adobe Dreamweaver the market leader in visual web-authoring tools, 

using it to create engaging websites for more than 11 years. The flexible development environment in 

Dreamweaver allows visually oriented designers to work in Design view to create their pages. By beginning 

with the CSS starter layouts, they can easily insert assets created in Adobe Photoshop® and Adobe Fireworks® 

software, or interactive elements created in Adobe Flash® Professional software. Using Live View in 

Dreamweaver, web designers can preview and interact with their pages as they will appear in standards-based 

browsers, making troubleshooting a more visual experience. Due to the extensible architecture in Dreamweaver, 

designers who want to add Ajax-based interface elements to their designs without writing any code can 

download third-party extensions from Adobe Exchange at www.adobe.com/cfusion/exchange. 

Web developers, who generally work in a more code-centric environment than their web designer counterparts, 

rely on professional coding tools in Dreamweaver to build not only static HTML pages, but also advanced web 

applications using back-end languages such as PHP and Adobe ColdFusion® software. As web developers 

build sites upon popular content management systems, they will be able to work on individual ―pieces‖ of the 

dynamic page while seeing the completely assembled page in Live View. Developers working within Code 

view quickly leverage timesaving features such as code hinting, code completion, and code snippets for their 

chosen server model as well as for client-side scripts written in JavaScript. Regardless of the language, 

developers using Dreamweaver are confident that their code is written as they expect—but should a syntax error 

inadvertently occur, real-time highlighting allows the developer to quickly spot and correct the problem. 

Top new features of Adobe Dreamweaver CS6 

Support for PHP-based content management systems 

With authoring and testing support for third-party PHP-based content management systems (CMS) like 

WordPress, Joomla, and Drupal, Dreamweaver CS6 delivers a professional development environment for 

creating robust websites. Dynamically Related Files provides direct access to the assets necessary for these 

complex systems, including dynamically generated pages and content. New Live View Navigation allows you 

to explore the various states of your dynamic applications and pages—even those already deployed on a live 

server. 

Dynamically Related Files 

One of the biggest challenges in developing sites with a web-based content management system such as 

Wordpress, Joomla, or Drupal is understanding how a page will look when finally assembled. This is primarily 

because a page itself is generated dynamically by the CMS from any number of individual pieces, known as 

includes, and is dependent on server-side logic to be viewed in a browser. The Dynamically Related Files 

http://www.adobe.com/cfusion/exchange
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feature in Dreamweaver CS6 helps you access files and update pages faster, as well as simplify management 

tasks for complex sites. With a single click, you can direct Dreamweaver to discover all of the external files and 

scripts necessary to assemble the page and display their filenames in the Related Files toolbar. With Live View 

enabled, Dreamweaver renders the page as it will appear in standards-compliant browsers, complete with 

dynamic, database-driven content and server- and client-side logic.  

Even the simplest pages in many of the popular CMS frameworks and themes have numerous dynamically 

related files, making it difficult to find the particular related files you need. With the ability to filter file types or 

use a wildcard expression, Dreamweaver lets you focus specifically on the files that you want to edit. If a 

related file doesn’t exist locally, Dreamweaver CS6 shows a prompt, and allows you retrieve the file from the 

server with a single click. 

 

Live View navigation 

Live View navigation expands upon the Live View feature introduced in Dreamweaver CS4 and allows you to 

quickly and accurately check your code and your CMS design themes. With Live View navigation enabled, not 

only can you view a page as it is rendered in standards-compliant browsers, but links are active, allowing you to 

interact with server-side applications and dynamic data. In addition to the rendered Live View of the page, Live 

Code highlights changes as they happen, allowing you to quickly locate the dynamically loaded data or code 

changes triggered by JavaScript. At any stage of development, Live View navigation also allows you to enter a 

URL to inspect pages served from a live web server and easily edit pages you have browsed to if they exist in 

one of your locally defined sites. 
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Enhanced CSS inspection tools  

By separating page markup (HTML) from the actual presentation of the content (CSS), web designs have 

become much more flexible and adaptable. However, for seasoned professionals and novices alike, there is a 

need to understand how page elements relate to one another, as well as to have the freedom to iterate and 

experiment with their page designs in real time. With enhanced CSS tools and Live View, Dreamweaver CS6 

gives you more control without having to leave your editing environment, even giving you the ability to view 

any link state and change text size—tasks that previously required a browser. 

The Inspect command 

Develop CSS-based designs more efficiently and accurately by visually displaying the CSS box model 

properties—including padding, border, and margin—in detail, without reading code or requiring a separate 

third-party utility such as Firebug. For designers who are new to web design or looking to expand their 

understanding of CSS, Dreamweaver CS6 makes it much easier to learn about the properties of an HTML 

element. In the past, external browser-based tools were required to visually identify page elements and their 

related CSS styles. This tedious process involved previewing the page in a browser, enabling the tool or plug-in, 

and then exploring the document to find the properties you wanted to change. Because this activity occurred in 

a browser, you had to keep track of all the changes made, and then copy and paste them into your web 

documents in Dreamweaver. In Dreamweaver CS6, you can use the Inspect command in tandem with Live 

View to quickly identify HTML elements and their associated CSS styles, giving you immediate feedback. 

 

When an element is highlighted in Live View, its corresponding CSS rules and cascade are exposed in the CSS 

Styles panel where they can be edited in real time, removing the need to copy from an external tool and paste 

the results into Dreamweaver. When inspecting in Split view, the corresponding HTML code—including the 

tag—is immediately selected. 
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CSS enable/disable 

Quickly and easily disable and re-enable CSS properties directly from the CSS Styles panel in Dreamweaver 

CS6. Disabling a CSS property simply comments out the specified property without actually deleting it, and the 

affected property is no longer rendered. This convenient option for toggling CSS properties on and off, coupled 

with the ability to inspect CSS, allows you to remain in your editing environment throughout the development 

process, eliminating the time-consuming process of previewing in the browser and troubleshooting with 

browser-based tools. 

 

Integration with Adobe BrowserLab 

Dreamweaver CS6 integrates with Adobe BrowserLab, one of the new CS Live online services, which provides 

a fast and accurate solution for cross-browser compatibility testing. Whether you are new to web design or a 

seasoned professional, you can use BrowserLab to preview web pages and local content with multiple viewing 

and comparison tools, customizing sets of browsers to meet your project’s requirements. While working within 

Dreamweaver CS6, you can interact with your page in Live View, including the ability to freeze JavaScript-

triggered interactions, and then send this ―snapshot‖ of the page directly to BrowserLab for an accurate preview 

in the specific browsers and operating systems you’ve chosen. For traditional designers who want to understand 

how the various browsers and browser versions render their content, Onionskin view in BrowserLab allows you 

to overlay the same page in two different browsers or browser versions to easily spot differences. 
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Enhanced support for Subversion 

With Dreamweaver CS6, you can manage files more effectively in collaborative, version-controlled 

environments with enhanced support for Subversion, an open-source version-control system. In Dreamweaver 

CS4, Subversion support was limited to the most basic functions of locking and unlocking files and generating 

status updates. Dreamweaver CS6 expands support for Subversion, allowing you to move, copy, and delete files 

locally, and then synchronize changes with your remote SVN repository. The new Revert command allows you 

to quickly correct tree conflicts or roll back to a previous version of a file. From the Repository View of the 

Files panel in Dreamweaver CS6, you can reduce clutter by directly performing svn:ignore commands to hide 

files you don’t need to access. To ensure future compatibility, the built-in Subversion libraries in Dreamweaver 

CS6 are designed to be updated by the Adobe Extension Manager. As newer versions of the Subversion 

libraries become available, they will be made available to the public as free extensions at Adobe Exchange at 

www.adobe.com/cfusion/exchange. 

 

http://www.adobe.com/cfusion/exchange


www.eacademy.lk         www.eacademy.lk 

7 | P a g e  
www.eacademy.lk 

PHP custom class code hinting 

Display proper syntax for PHP functions, objects, and constants to help you write code more accurately. 

Dreamweaver CS6 provides enhanced PHP code hinting on the fly by dynamically parsing PHP code and 

updating it as you type—even with code that hasn’t yet been saved to disk. The code hints for PHP core 

functions and objects include the function signature, the module that defines the function, a description tooltip 

that mentions the PHP versions in which it is available, the method and parameter descriptions, and a link to the 

PHP.net manual page. Code hinting also works with your own custom functions and classes, as well as with 

third-party frameworks such as the Zend Framework. Dreamweaver CS6 dynamically highlights errors and 

provides alerts in the Information bar to help you more efficiently find and fix errors in your PHP code. 

 

Site-specific code hints 

As sites become more and more customized, especially those built using content management systems and/or 

custom plug-ins, the need to edit customized code efficiently becomes more important than ever. Site-specific 

code hints within Dreamweaver help you to more efficiently handle PHP coding tasks on a site-by-site basis. 

Theme files for blogs and other custom PHP files and directories can be included (or excluded) to customize the 

coding environment of Dreamweaver CS6 when working with third-party PHP libraries and CMS frameworks 

such as WordPress, Drupal, and Joomla and others. For robust code hinting, you can also specify files and even 

folders located outside of the defined site root. 
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Enhanced CSS starter layouts 

Jump-start your standards-based website design with updated and simplified CSS starter layouts. Based on user 

feedback and constantly evolving CSS best practices, the CSS starter layouts have been completely rewritten. 

For example, complex descendent selectors have been removed in favor of simplified, easy-to-understand 

classes, and the overall structure of the documents has been revamped. To help ensure success with the new 

layouts, instructions and comments are included both in the CSS code and the text of the document. Regardless 

of your experience, CSS starter layouts speed your development time by providing a variety of solid structures 

upon which to build your designs. For print designers and others just making the move to web design, CSS 

starter layouts can dramatically speed up the learning process. 

 

Simple site setup 

To help make setup faster and easier, the Site Definition dialog box has been extensively redesigned, 

implementing many improvements suggested by web designers and developers who use Dreamweaver on a 

regular basis. You can start with as much or as little detail as you like— even with just a site name and local site 

folder—and Dreamweaver will prompt you for the remaining details as they’re needed as you build your site. 

For more advanced projects, you can specify multiple servers with custom names to utilize staged, networked, 

or other server types. 
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Integration with Adobe Business Catalyst 

In today’s competitive environment, your clients demand more from their websites—they want true business 

results. With the Adobe Business Catalyst® extension for Dreamweaver (available separately and in English 

only) and the Business Catalyst online service* (available separately) you can deliver powerful online 

businesses without programming and at a fraction of the time and cost—all from within your familiar 

Dreamweaver workspace. Business Catalyst is an online service that can replace as many as five or more 

applications and tools with a single central platform for web designers that works hand in hand with 

Dreamweaver through the Business Catalyst extension for Dreamweaver. Using the unified platform and 

without back-end coding, you can build everything from amazing websites to powerful online stores, and from 

beautiful brochure-ware sites to lead generating mini-sites. 

 

Adobe Dreamweaver CS6 workspace 

You can access Adobe Dreamweaver CS6 tools, commands, and features by using menus or by selecting 

options from one of the Insert panels or other Dreamweaver panels. The most commonly used areas of the 

Dreamweaver workspace are the Document window, the Insert panel, the Properties panel, and the other panels. 
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The Document window displays the current document as you create and edit it. The Insert panel contains 

buttons for creating and inserting objects such as images, tables, layers, and frames you might want to add to 

your web pages. The Properties panel displays properties for the selected object or text and enables you to 

modify those properties. 

The Document window and panels 

The Dreamweaver workspace enables you to view documents and object properties. The workspace places 

many of the most common operations in toolbars so that you can quickly make changes to your documents. 

Switching between views 

Dreamweaver enables you to work in a variety of views. Lay out a page graphically in Design view, work 

directly with the underlying code, split the screen into both Code and Design views, or edit in Live view which 

presents a non-editable browser-based rendering of the document as you create and edit it. Change views by 

using the view buttons. 

• Code view - a hand-coding environment for writing and editing HTML, JavaScript, server-language code— 

such PHP or ColdFusion Markup Language (CFML)—and any other kind of code. 

• Design view - a design environment for visual page layout, visual editing, and rapid application development. 

In this view, Dreamweaver displays a fully editable, visual representation of the document, similar to what you 

would see when viewing the page in a browser. 

• Code and Design view (Split view) - both Code view and Design view for the same document in a single 

window. 

There are also two additional views related to code that dynamically changes the page--that is, code that will 

change as users interact with the page: 

• Live view - similar to Design view, a more realistic representation of what your document will look like in a 

browser. Live view enables you to interact with the document exactly as you would in a browser. Live view is 

not editable. However, you can edit in Code view and refresh Live view to see your changes. 

• Live Code view - only available when viewing a document in Live view. Live Code view displays the actual 

code that a browser uses to execute the page, and can dynamically change as you interact with the page in Live 

view. Live Code view is not editable. 

To select a view, click its button in the Document toolbar. 

Dreamweaver workspaces 

You can also manage panels by using workspaces. Workspaces are pre-arranged panel settings optimized for 

specific tasks or work styles. 

To switch between workspaces: 

1. Select a new workspace, such as the Designer Compact workspace, from the workspace switcher in the 

Application bar. The panels are rearranged. 
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To create a new workspace: 

1. Make changes to an existing workspace, such as by opening new panels or closing open panels. 

2. Choose Window > Workspace Layout > New Workspace. The New Workspace dialog box (Windows) or 

Save Workspace dialog box (Mac OS) opens. 

3. Enter a name for the new workspace. 

4. Click OK. 

The workspace is now available in the workspace switcher and the Workspace Layout menu. 

 

Panels 

Depending on the selected workspace, the right side of the workspace displays panels. 

Panel groups 

Panels are often arranged into groups. Panel groups are panels that are docked together. For example, the Files 

and Assets panels are docked together by default in the Designer workspace. 
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• To move a panel into a group, drag the panel’s tab to the highlighted drop zone in the group. 

• To rearrange panels in a group, drag a panel’s tab to a new location in the group. 

• To remove a panel from a group so that it floats freely, drag the panel by its tab outside the group. 

• To move a floating group, drag the title bar (the area above the tabs). 

Working with Panels 

• Opening and closing panels: To open a panel, select it from the Window menu. To close a panel, do one of the 

following: 

 Click the Close button at the top of a floating panel. 

 Choose Close from the panel menu. 

 Deselect the panel in the Window menu. 

• Moving panels and panel groups. To move a panel, drag it by its tab. To move a panel group or a stack of 

floating panels, drag the title bar. To dock a panel, drag the panel until the border changes to blue. Release the 

mouse to dock the panel. To undock the panel, drag it away from the left border. 

• Minimizing or maximizing panels: To minimize or maximize a panel, double-click the tab or the tab area (the 

empty space next to the tab). 

• Collapsing panels: Collapsing a panel makes it available as an icon. To collapse or expand a panel, do one of 

the following: 

 Click the double arrow in a floating panel's title bar. 

 Double-click the tab area. 

 Double-click the title bar of a floating panel or group. 

 

• Docking and undocking panels: As you move panels, you see blue highlighted drop zones. Drop zones are 

areas where you can dock the panel. If you drag to an area that is not a drop zone, the panel floats freely in the 

workspace. 

• Resizing panels: To resize a panel, drag either its left or bottom border. All panels have a minimum size 

beyond which they cannot be minimized. Panels can be maximized to fill your screen. 

Commonly used panels 

The Files panel displays the organization of your site and enables you to open files for editing, to publish files 

to a server, or to delete files. The Assets panel contains all site assets, elements used in a site, such as images, 

colors, or movies. The Assets panel provides two ways to view assets: 



www.eacademy.lk         www.eacademy.lk 

13 | P a g e  
www.eacademy.lk 

• The Site list shows all of the assets in your site. 

• The Favorites list shows only the assets you’ve chosen to include in the Favorites list. 

The Insert panel 

The Insert panel contains buttons for creating and inserting objects such as tables, images, and links. The 

buttons are organized into several categories (Common, Layout, Forms, Data, and more), which you can choose 

from the Category pop-up menu. Additional categories appear when the current document contains server code, 

such as ASP or CFML documents. 

Common category in the Insert panel 

The Common category in the Insert panel contains buttons for inserting the most commonly used objects 

(Figure 6). 

 

 Hyperlink: Insert a hypertext link. 

 Email Link: Insert a link to an e-mail address. 

 Named Anchor: Insert a link to a specific location on a page. 

 Horizontal Rule: Insert a horizontal rule to visually separate sections on a page. 

 Table: Insert a table. 

 Insert Div Tag: Insert a div tag used for page layout. 

 Images: Insert an image. 

 Media: Insert media objects, such as Flash, Shockwave, Applets, and ActiveX. 

 Widget: Insert a Dreamweaver widget. 
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 Date: Insert the current date, with an option for automatic updating when you save the document. 

 Server-Side Include: Use as a placeholder for commonly used code that can be reused by many pages in 

your site. When you use a SSI file the server takes the entire content of the file stored on a server and 

inserts it into the page, replacing the include code. 

 Comment: Insert a comment, which will not be displayed on your web page. 

 Head: Insert keywords, meta tags, page descriptions, and other document data that is kept in the page’s 

head tag. 

 Script: Insert or remove script, such as Javascript. 

 Templates: Make a template based on the current document. 

 Tag Chooser: Insert an HTML tag. 

Layout Category in the Insert Panel 

From the Layout category in the Insert panel, you can insert tables, table elements, div tags, frames, and Spry 

widgets. You can choose between two modes for tables. Standard mode displays a table as a grid of lines. 

Expanded Tables mode adds cell padding and spacing to tables and increases table borders to make editing 

easier. 

 

 Insert Div Tag: Insert a div tag to create a content block. 

 Insert Fluid Grid Layout Div Tag: Insert a flexible-positioned div tag to display content at a variable 

location on the page. 

 Draw AP Div: Insert an absolutely-positioned div tag to hold content at a specific location on the page. 

 Spry Menu Bar: Insert a set of navigational menu buttons that display submenus when a site visitor 

hovers over one of the buttons. 

 Spry Tabbed Panels: Insert tabs that a site visitor can click to reveal hidden content. 
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 Spry Accordion: Insert a set of collapsible panels that can store a large amount of content in a compact 

space. 

 Spry Collapsible Panel: Insert a panel that can hide or reveal a large amount of content when a site 

visitor clicks the tab of the panel. 

 Table: Insert a table. 

 Insert Row Above: Insert a row above the current row in a table. 

 Insert Row Below: Insert a row below the current row. 

 Insert Column to the Left: Insert a column to the left of the current column. 

 Insert Column to the Right: Insert a column to the right of the current column. 

The Property panel 

In the Property panel, you can view and change a variety of properties for the currently selected object, tool, or 

document. Each kind of element has different properties. This figure shows the Properties panel for a selected 

image. It displays the source location, Alt tag, dimensions, and class. You can edit these settings and create 

links in the Properties panel. 

 

 

How to set up a local root folder and site structure 

A Dreamweaver site is a collection of all the files and assets in your website. You can create web pages on your 

computer, upload them to a web server, and maintain the site by transferring updated files whenever you save 

them. You can also edit and maintain websites that were created without using Dreamweaver. 

What is a Dreamweaver “site”? 

In Dreamweaver the term ―site‖ refers to a local or remote storage location for the documents that belong to a 

website. A Dreamweaver site provides a way to organize and manage all of your web documents, upload your 

site to a web server, track and maintain your links, and manage and share files. You should define a site to take 

full advantage of Dreamweaver features. 

Note: To define a Dreamweaver site, you only need to set up a local folder. To transfer files to a web server or 

to develop web applications, you must also add information for a remote site and testing server. 

A Dreamweaver site consists of as many as three parts, or folders, depending on your development environment 

and the type of website you are developing: 

Local root folder stores the files you’re working on. Dreamweaver refers to this folder as your ―local site.‖ This 

folder is typically on your local computer, but it can also be on a network server. 

Remote folder stores your files for testing, production, collaboration, and so on. Dreamweaver refers to this 

folder as your ―remote site‖ in the Files panel. Typically, your remote folder is on the computer where your web 

server is running. The remote folder holds the files that users access on the Internet. Together, the local and 



www.eacademy.lk         www.eacademy.lk 

16 | P a g e  
www.eacademy.lk 

remote folders enable you to transfer files between your local hard disk and web server, making it easy to 

manage files in your Dreamweaver sites. You work on files in the local folder, and then publish them to the 

remote folder when you want other people to view them. 

Testing server folder is the folder where Dreamweaver processes dynamic pages. 

Understanding local and remote folder structure 

When you want to use Dreamweaver to connect to a remote folder, you specify the remote folder in the Servers 

category of the Site Setup dialog box. The remote folder that you specify (also referred to as the ―host 

directory‖) should correspond to the local root folder of your Dreamweaver site. (The local root folder is the 

top-level folder of your Dreamweaver site.) Remote folders, like local folders, can have any title, but 

commonly, Internet Service Providers (ISPs) name the top-level remote folders for individual user accounts 

public_html, pub_html, or something similar. If you are in charge of your own remote server, and can name the 

remote folder anything you want, it is a good idea for your local root folder and remote folder to have the same 

name. 

 

Note: The above example illustrates one local root folder on the local machine, and one top-level remote folder 

on the remote web server. If, however, you are maintaining a number of Dreamweaver sites on your local 

machine, you would need an equal number of remote folders on the remote server. In such a case the above 

example would not apply, and you would instead create different remote folders within the public_html folder, 

and then map them to their corresponding local root folders on your local machine. 

When you first establish a remote connection, the remote folder on the web server is usually empty. Then, when 

you use Dreamweaver to upload all of the files in your local root folder, the remote folder populates with all of 

your web files. The directory structure of the remote folder and the local root folder should always be the same. 

(That is, there should always be a one-to-one correspondence between the files and folders in your local root 

folder, and the files and folders in your remote folder.) If the structure of the remote folder doesn’t match the 

structure of the local root folder, 

Dreamweaver uploads files to the wrong place, where they might not be visible to site visitors. Additionally, 

image and link paths can easily break when folder and file structures are not in synch. The remote folder must 

exist before Dreamweaver can connect to it. If you don’t have a designated folder that acts as your remote 

folder on the web server, create one or ask your ISP’s server administrator to create one for you. 
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Setting up a local root folder 

To set up a local version of your site, all you need to do is specify the local folder where you’ll store all of your 

site files. The local folder can be on your local computer or on a network server. 

To set up a local root folder: 

1. Identify or create the folder on your computer where you want to store the local version of your site files. 

(The folder can be anywhere on your computer.) You’ll specify this folder as your local site in Dreamweaver. 

This folder is called the local root folder. 

2. Start Dreamweaver. 

3. Choose Site > New Site. The Site Setup dialog box opens. 

4. In the Site Setup dialog box, make sure the Site category is selected. (It should be selected by default.) 

5. In the Site Name text box, enter a name for your site. This name appears in the Files panel and in the Manage 

Sites dialog box; it does not appear in the browser. 

6. In the Local Site Folder text box, click the Browse To Folder icon, browse to and select the local root folder 

you created, and click Select (Windows) or Choose (MacOS). Your local root folder is defined in 

Dreamweaver. 

7. Click Save to close the Site Setup dialog box. You can now begin working on your local site files in 

Dreamweaver. On the right side of the Dreamweaver workspace, the Files panel displays the folders and files of 

your site. 

Note: When you’re ready, you can fill out the other categories in the Site Setup dialog box, including the 

Servers category, where you can specify a remote folder on your remote server. 
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Modifying site information 

The Manage Sites dialog box is your gateway into various Dreamweaver site functions. From this dialog box, 

you can initiate the process for creating a new site, editing an existing site, duplicating a site, removing a site, or 

importing or exporting a site’s settings. 

To modify site information: 

1. Select Site > Manage Sites. The Manage Sites dialog box opens. 

2. Select the site name and click the Edit button. The Site Setup dialog box opens. 

3. Click a button to select one of the options, make any changes you need to make, and click Save or Cancel to 

close the Site Setup dialog box. Click Done to close the Manage Sites dialog box. 

 

How to set document properties 

For each page you create in Dreamweaver, you can specify layout and formatting properties by using the Page 

Properties dialog box. The Page Properties dialog box lets you specify the default font family and font size, 

background color, margins, link styles, and many other aspects of page design. You can assign new page 

properties for each new page you create, and modify those for existing pages. You can also change the 

Document Type Declaration in the Title/Encoding category of the Page Properties dialog box. For example, if 

you wanted to alter a document’s DTD from HTML 4.1 to HTML 5. Changes you make in the Page Properties 

dialog box apply to the entire page. 

Dreamweaver gives you two methods for modifying page properties: CSS or HTML. Adobe recommends using 

CSS to set backgrounds and modify page properties. 
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Using CSS to set font, colors, margins, and background image properties 

Use the Page Properties dialog box to specify several basic page layout options for your web pages, including 

the font, background color, and background image. 

To set layout and formatting options for a page: 

1. Open a document in Adobe Dreamweaver CS6. 

2. Select Modify > Page Properties or click the Page 

Properties button in the text Properties panel. The Page Properties dialog box opens. 

3. Select the Appearance (CSS) category and set the options. 

Page Font specifies the default font family to use for the page. Dreamweaver uses the font family you specify 

unless another font is specifically set for a text element. 

Size specifies the default font size to use in the page. Dreamweaver uses the font size you specify unless another 

font size is specifically set for a text element. 

Text Color specifies the default color to render fonts with. 

Background Color sets a background color for your page. Click the Background color box and select a color 

from the color picker. 

Background Image sets a background image for the page. Click the Browse button, then browse to and select 

the image. Alternatively, enter the path to the background image in the Background Image text box. 

Dreamweaver tiles (repeats) the background image if it does not fill the entire window, just as browsers do. 

Repeat text specifies how the background image will be displayed on the page: 

• Select the No-repeat option to display the background image only once. 

• Select the Repeat option to repeat, or tile, the image both horizontally and vertically. 
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• Select the Repeat-x option to tile the image horizontally. 

• Select the Repeat-y option to tile the image vertically. 

Left Margin and Right Margin specify the size of the left and right page margins. 

Top Margin and Bottom specify the size of the top and bottom page margins. 

4. When you’ve finished making changes, click Apply to set the properties, and click OK to close the dialog 

box. 

 

How to use the Assets panel 

You can use the Assets panel in Dreamweaver CS6 to manage assets in the current site. The Assets panel 

displays assets for the site associated with the active document in the Document window. A library item is a 

special category of assets that can automatically update all instances of a library item whenever you edit the 

item The Assets panel provides two ways to view assets: 
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Site list shows all of the assets in your site, including colors and URLs that are used in any document in your 

site. 

Favorites list shows only the assets you’ve explicitly chosen. To switch between these two views, select either 

the Site or Favorites radio button above the preview area. (These two views are not available for the Templates 

and Library categories.) 

In both lists, assets fall into one of the following categories: 

• Images image files in GIF, JPEG, or PNG formats. 

• Colors colors used in documents and style sheets, including colors of text, backgrounds, and links. 

• URLs external links in your current site documents, including FTP, gopher, HTTP, HTTPS, JavaScript, 

e-mail (mailto), and local file (file://) links. 

• Flash files in any version of Adobe Flash. The Assets panel displays only SWF files (compressed files 

created with Flash), not FLA (Flash source) files. 

• Shockwave files in any version of Adobe Shockwave. 

• Movies QuickTime or MPEG files. 

• Scripts JavaScript or VBScript files. Scripts in HTML files (rather than in independent JavaScript or 

VBScript files) do not appear in the Assets panel. 

• Templates master page layouts used on multiple pages. Modifying a template automatically modifies all 

pages attached to it. 

• Library items design elements that you use in multiple pages; when you modify a library item, all pages 

containing that item are updated. 

By default, assets in a category are listed alphabetically by name, but you can sort them by type and several 

other criteria. You can also preview assets and resize the columns and the preview area. 

Add an asset to a document 

You can insert most assets into a document by dragging them into Code view or Design view in the Document 

window, or by using the Insert button in the Assets panel. You can either insert colors and URLs or apply them 

to selected text in Design view. (URLs can also be applied to other elements in Design view, such as images.) 

To add an asset to a document: 

1. Start Dreamweaver. 

2. In Design view, place the insertion point where you want the asset to appear. 

3. In the Assets panel, select from the asset category buttons at the left. 

Note: Select any category except Templates. A template is applied to an entire document; it can’t be inserted 

into a document. 

4. Select either Site or Favorites at the top of the panel, then select the asset. 

5. Do one of the following: 

• Drag the asset from the panel to the document. You can drag scripts into the head content area of the 

Document window; if that area isn’t visible, select View > Head Content. 

• Select the asset in the panel and click the Insert button. If the inserted asset is a color, it applies to text 

appearing after the insertion point. 



www.eacademy.lk         www.eacademy.lk 

22 | P a g e  
www.eacademy.lk 

 

6. If you are adding an image asset, and enabled Accessibility preferences (Edit > Preferences > Accessibility in 

Windows, Dreamweaver > Preferences > Accessibility in Mac OS), you will be presented with the Image Tag 

Accessibility Attributes dialog box. Enter a description of the image in the Alternate Text box. 

 

Edit an asset 

When you edit an asset in the Assets panel, the behavior varies according to the asset type. For some assets, 

such as images, you use an external editor, which opens automatically if you have defined an editor for that 

asset type. You can edit colors and URLs in the Favorites list only. When you edit templates and library items, 

you make the changes within Dreamweaver. 

To edit an asset: 

1. In the Assets panel, do one of the following: 

• Double-click the asset. 

• Select the asset, then click the Edit button. 

Note: If the asset must be edited in an external editor and one doesn’t open automatically, select Edit > 

Preferences (Windows) or Dreamweaver > Preferences (Mac OS), select the File Types/Editors category, and 

define an external editor for that asset type. 
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2. Make your changes. For example, in Figure 4, Fireworks opens in order to edit a selected button asset. 

 

3. When you finish, do one of the following: 

• If the asset is file-based (anything other than a color or URL), save it (in the editor you used), and close 

the external editor. 

• If the asset is a URL, click OK in the Edit URL dialog box. 

Note: If the asset is a color, the color picker closes automatically after you pick a color. To dismiss the color 

picker without picking a color, press Esc. The file is saved and updated within the Assets panel. 

How to use libraries 

You can use a library in Adobe Dreamweaver CS6 to store page elements such as images, text, sounds, or tables 

you want to reuse throughout your website. When you insert a library item, Dreamweaver inserts a link to the 

library item. If you later need to make changes to a library item, such as changing some text or an image, 

updating the library item automatically updates each instance of the item on every page into which you’ve 

inserted it. 
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Creating a library item 

You create library items out of existing page elements. 

To create a library item: 

1. In the Document window, select the element (such as an image or text) to save as a library item. 

2. In the Assets panel, click the Library button. 

3. Click the New Library Item button at the bottom of the panel. 

4. Type a name for the new library item, then press Enter (Windows) or Return (Mac OS). 

 

Dreamweaver saves each library item as a separate file (with the file extension .lbi) in the Library folder of the 

site’s local root folder. 

Inserting a library item 

Once an item is added to the Library, you can insert it onto a page. 

To insert a library item: 

1. Position the insertion point in the Document window where you want to insert a library item. 

2. In the Assets panel, click the Library button. 

3. Drag a library item from the Assets panel to the Document window, or select an item and click the Insert 

button at the bottom of the panel. 
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Editing a library item 

Library items can be edited in their own window. The changes you make then apply to the library item 

everywhere you have previously inserted it. 

To edit a library item: 

1. In the Assets panel, click the Library button. 

2. Select a library item. 

3. Click the Edit button at the bottom of the Assets panel. Dreamweaver opens a new window for editing the 

library item. This window is much like a Document window. You can tell it is a library item by the .lbi filename 

extension on the document’s tab. 

4. Edit the library item and then save your changes. The Update Library Items dialog box opens, with a list of 

the files that use the library item. 

5. Click Update to replace the original library item with your edited version in the files that use the library item. 

The Update Pages dialog box opens. 

6. To see a report on the updating process, make sure Show Log is selected. 

7. Click Close. 
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Updating all documents to use current library items 

If you do not choose to update documents that use library items as you edit individual library items, you can 

later update all pages in the site with the current version of all library items. 

To documents to use current library items: 

1. Select Modify > Library > Update Pages. The Update Pages dialog box opens. 

2. From the Look In pop-up menu, select Entire Site, and then select the site name from the adjacent pop-up 

menu. 

3. Make sure Library Items is selected in the Update section. 

4. Click Start. 

Dreamweaver updates the documents and provides a report on the updating process (Figure 12). If you have 

updated documents at the time you edited library items, this report confirms that no additional updating was 

required. 

5. Click Close. 

 

How to manage files and links by using the Files panel 

The Files panel in Dreamweaver helps you manage files and links. Use the Files panel to open, add, rename, or 

delete files and folders. Use the Files panel to modify links. 

Opening files 

Use the Files panel to view and manage the files in your Dreamweaver site. To open a file: 

1. In the Files panel (Window > Files), select a site, server, or drive from the Current Sites pop-up menu. 

2. In the Local Files section, navigate to the file you want to open. 

3. Do one of the following: 

• Double-click the files's icon. 

• Right-click (Windows) or Control-click (Mac OS) the file's icon, then select Open. 
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Note: If Check In/Check Out is enabled, Dreamweaver will check the file out before it opens the file. If another 

visitor has checked out the file, Dreamweaver will warn you about the file’s status and let you know who has it 

checked out. You can then decide whether to continue opening the file or not. 

 

Renaming files 

When you rename a file in the Files panel, Dreamweaver can automatically change links that point to this file. 

For this reason, it is always preferable to rename site files by using the Files panel instead of renaming them on 

your hard disk. 

To rename a file: 

1. In the Files panel, select the file or folder you want to rename. 

2. Do one of the following to activate the name of the file or folder: 

• Click the name, pause, and then click again. 

• Right-click (Windows) or Control-click (Mac OS) the file or folder icon, and then select Edit > Rename. 

3. Type the new name over the existing name. 

4. Press Enter (Windows) or Return (Mac OS). If any site links point to the file or folder, the Update Files 

dialog box opens. 

5. Click Update to change links that point to the renamed file or to a file in the renamed folder. 
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Deleting files 

When you delete a file or folder, Dreamweaver will warn you if links in other documents point to the file or 

folder. 

To delete a file: 

1. Click the file or folder in the Files panel you want to delete. 

2. Press Delete. If any site links point to the file or folder, the Delete Files warning opens, giving you the 

opportunity to change the links before you delete the file. 

 

To delete the file anyway, click Yes. To cancel your request to delete the file, click No. 

Changing links to a file 

You can also change links to a file through the Files panel. It is a good practice to change links before you 

delete a file to which other files are linked. 

To change links to a file: 

1. Select a file in the Files panel. Select Site > Change Link Sitewide. The Change Link Sitewide dialog box 

opens. 

 

2. In the Into Links To text box, enter the name of the file to which new links should point. 

3. Click OK. The Update Files dialog box opens. 

4. Click Update. 
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Creating a new folder 

Use folders to keep your site well organized. For example, most websites use a folder named images to store all 

the images for the site. 

To create a new folder: 

1. Select the site root folder (or another folder in which you want to create a nested folder). 

2. In the Files panel menu, select File > New Folder. Dreamweaver creates a new folder inside the selected 

folder. The folder name is selected. 

3. Enter a name for the new folder and press Enter. (Windows) or Return (Mac OS). 

 

The Dreamweaver Insert panel 

In Adobe Dreamweaver CS6, the Insert panel contains buttons for inserting various types of objects, such as 

images and forms, into a Dreamweaver document. You can use the Insert panel to create or insert content in 

eight categories: 

• The Common category contains buttons for inserting the most commonly used objects, such as links, images, 

and tables. 

• The Layout category gives you options to insert tables, table elements, div tags, frames, and Spry widgets. 

You can view tables in either Standard (default) mode or Expanded Tables mode. 

• The Forms category contains buttons for creating forms and inserting form elements. 

• The Data category lets you insert dynamic elements such as recordsets, repeated regions, and record insertion 

and update forms. 

• The Spry category lets you insert ―widgets‖ that display data from other files and various interface elements 

(such as navigation bars and menus) that rely on JavaScript and CSS. (Spry widgets are not covered in this 

study, but you can read find out more about them in Dreamweaver Help (select Help > Dreamweaver Help and 

look for the section called ―Building Spry pages visually.‖) 
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• The jQuery Mobile category provides content layout options, input, UI and form controls for developing 

mobile applications using Dreamweaver. 

• The InContext Editing category is used to enable end users to make simple edits to their web pages without 

help from you or additional software on their computers. Adobe InContext Editing (ICE) is an online hosted 

service that provides simple content editing capabilities within a web browser. 

• The Text category is used for working in Code view and enables you to insert a variety of text- and 

listformatting tags, such as b, em, p, h1, and ul. 

• Use the Favorites category to customize a list of Insert panel buttons for fast access. You can customize this 

category by right-clicking (Windows) or Control-clicking (Mac OS) the Insert panel. 

You switch between these categories by using the Insert panel menu, which is located at the top of the Insert 

panel. To hide or show the Insert panel select Window > Insert. 

 

To display the pop-up menu for a button, click the disclosure triangle beside the button’s icon. 
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How to create and edit a CSS rule 

You can create and edit a CSS rule in two locations: the Properties panel and the CSS Styles panel. When you 

apply CSS styles to text by using the Properties panel or menu commands, CSS rules are embedded in the head 

of the current document. You can also use the CSS Styles panel to create and edit CSS rules and properties. 

In this guide, you review CSS rules, create and apply a class-style CSS rule by using the Properties panel, and 

modify an HTML tag-style rule by using the CSS Styles panel. 

About CSS rules 

 

A CSS formatting rule consists of two parts: the selector and the declaration (or in most cases, a block of 

declarations). The selector is a term (such as p, h1, a class name, or an id) that identifies the formatted element. 

The declaration block defines the style properties. In the following example, h1 (a heading tag) is the selector, 

and everything that falls between the braces ({and }) is the declaration block (defining the properties of the h1 

heading): 
 

h1 { 

font-family: Georgia, "Times New Roman", Times, serif; 

font-size: 18px; 

text-transform: uppercase; 

color: # 

An individual declaration consists of two parts: the property (such as font family) and value (such as Georgia). 

In the previous CSS rule, a particular style has been created for h1 tags; the text for all h1 tags linked to this 

style will be 18 pixels in size, Georgia font, uppercase, and bright green (hex value #090). 

The style (which comes from a rule, or a collection of rules) resides in a place separate from the actual text it’s 

formatting—usually in an external style sheet or in the head section of an HTML document. Thus, one rule for 

h1 tags can apply to many tags at once and in the case of external style sheets, the rule can apply to many tags at 

once on many different pages. 

In this way, CSS provides extremely easy update capability. When you update a CSS rule in one place, the 

formatting of all the elements that use the defined style is automatically updated to the new style. 

There are three main types of CSS: 

Class style: Similar to the styles you use in word processing and page layout programs. For example, you may 

want to format all body text in 10-point, Arial, dark green type. You can create a class style with these attributes 

and then apply this style to all body text in your website. Class names must begin with a period and can contain 

any combination of letters and numbers (for example, .myhead1). 

HTML tag style: Applies global formatting to individual HTML tags rather than to individual selections. 

Suppose you want to modify the Heading 1 paragraph style to appear always in purple text. Instead of creating a 

class style and applying it to every heading in the document, you can create an HTML tag style with these 

attributes and apply it to the Heading 1 <h1> tag. In effect, you are redefining the HTML tag. 

ID style: A unique identifier (ID) for a style applied to headers, banners, menus, and other elements present in 

only one location in the document. Used once within a document or page. IDs must begin with a pound (#) sign 

and can contain any combination of letters and numbers (for example, #myID1). 
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CSS rules can reside in the following locations: 

• Internal (or embedded) CSS style sheets are collections of CSS rules included in a style tag in the head 

section of an HTML document. 

• External CSS style sheets are collections of CSS rules stored in a separate, external CSS (.css) file (not 

an HTML file). You link this file to one or more pages in a website with a link or an @import rule in the 

head section of a document. 

Creating a new CSS rule from the Properties panel 

In the CSS Properties panel, you can access Targeted Rules and create new ones. A Targeted Rule is a rule you 

are editing in the CSS Properties panel. When you have an existing style applied to text, the rule affecting the 

text’s format appears when you click inside the text on the page. You can also use the Targeted Rule pop-up 

menu to create new CSS rules and new in-line styles or apply existing classes to selected text. 

 

Properties panel, CSS mode 

How you edit your CSS depends on selection level. To access rules that apply to a current selection only, you 

can use the Targeted Rule pop-up menu in the CSS Properties panel. To access all CSS rules for a page, you can 

use the CSS Styles panel. The CSS Styles panel will be reviewed in the next guide. In this section, you use the 

Properties panel to create a simple CSS class-style rule to format a block of text. 

How you edit your CSS depends on selection level. To access rules that apply to a current selection only, you 

can use the Targeted Rule pop-up menu in the CSS Properties panel. To access all CSS rules for a page, you can 

use the CSS Styles panel. 

Applying CSS styles 

After you create a CSS rule, you can use it to give your entire document or website a consistent appearance. 

You can apply a CSS rule to text by using the Properties panel. 

To apply a CSS style: 

1. Click anywhere in the paragraph that doesn’t have the new CSS style. 

2. In the Properties panel, select myStyle (the new CSS rule you just created) from the Targeted Rule menu. The 

new style is applied to the other paragraph. 

Note: If you edit the CSS style, both paragraphs will be updated automatically and consistently. You will learn 

more about creating and modifying CSS in a later guide. 

Using the CSS Styles panel 

In the CSS Styles panel you can track the CSS rules and properties affecting a currently selected page element 

(Current mode) or all of the rules and properties available to the document (All mode). A button at the top of the 
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panel enables you to switch between the two modes. You can also use the CSS Styles panel to modify CSS 

properties in both All and Current modes. 

The CSS Styles panel in Current mode 

In Current mode, the CSS Styles panel displays three panes: a Summary For Selection pane that displays the 

CSS properties for the current selection in the document, a Rules pane that displays the location of selected 

properties (or a cascade of rules for the selected tag, depending on your selection), and a Properties pane where 

you can edit CSS properties for the rule applied to the selection. 

 

The CSS Styles panel in All mode 

In All mode, the CSS Styles panel displays two panes: an All Rules pane, and a Properties pane. The All Rules 

pane displays a list of rules defined in the current document as well as all rules defined in style sheets attached 

to the current document. You can use the Properties pane to edit CSS properties for any rule selected in the All 

Rules pane. 
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How to lay out a web page with CSS 

A CSS page layout uses the Cascading Style Sheets format, rather than traditional HTML tables or frames, to 

organize the content on a web page. The basic building block of the CSS layout is the div tag—an HTML tag 

that in most cases acts as a container for text, images, and other page elements. When you create a CSS layout, 

you place div tags on the page, add content to them, and position them in various places. Unlike table cells, 

which are restricted to existing somewhere within the rows and columns of a table, div tags can appear 

anywhere on a web page. You can position div tags absolutely (by specifying x and y coordinates), or relatively 

(by specifying their distance from other page elements). You can also position div tags by specifying floats, 

paddings, and margins—the preferred method by today’s web standards. 

Creating CSS layouts from scratch can be difficult because there are so many ways to do it. You can create a 

simple two-column CSS layout by setting floats, margins, paddings, and other CSS properties in a nearly 

infinite number of combinations. Additionally, the problem of cross-browser rendering causes certain CSS 

layouts to display properly in some browsers and improperly in others. Dreamweaver makes it easy for you to 

build pages with CSS layouts by providing 16 pre-designed layouts that work across different browsers. 

Using the pre-designed CSS layouts is the easiest way to create a page with a CSS layout, but you can also 

create CSS layouts by using absolutely-positioned elements (AP elements). An AP element in Dreamweaver is 

an HTML page element—specifically, a div tag or any other tag—that has an absolute position assigned to it. 

The limitation of Dreamweaver AP elements, however, is that since they are absolutely positioned, their 

positions never adjust on the page in relation to the size of the browser window. 

 

Once you become more experienced you will be able to create page layouts by inserting div tags manually and 

applying CSS positioning styles to them. 

Inserting an AP div tag 

Start this activity by creating a new, blank page and inserting an AP div tag. AP elements can contain text, 

images, or any other content that you can place in the body of an HTML document. 

You can resize an individual div or simultaneously resize multiple divs to make them the same width and 

height. 
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You can move divs in Design view in much the same way you move objects in most basic graphics 

applications. You can add images, text, and other content (such as Flash movies) to your divs just as you would 

elsewhere in a web page. 

How to use templates 

You can use an Adobe Dreamweaver CS6 template to create multiple pages with the same layout. In a template, 

you control which page elements should remain constant in documents based on that template and which 

elements can be changed from page to page. Templates are helpful for building a website in which most pages 

have the same header, navigation system, and other elements. Using templates helps you save time as well as 

create and maintain a consistent look when more than one person is developing a site. 

Creating a template 

You create templates from existing pages, setting editable regions on these pages that will hold content on each 

page created from the template. 

To create a template: 

1. Start Dreamweaver. 

2. Build a page that contains elements designed to appear on all content pages such as common graphics, a 

navigation bar, and common layout structures such as div tags. 

Note: You may want to create navigation elements in Adobe Fireworks CS6 and export them as HTML 

documents. 

3. Select File > Save As Template. 

4. In the Save As Template dialog box, give the template a name. You can also enter a brief description of the 

template. Then click Save. If Dreamweaver asks if you want to update links, click Yes. 
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Dreamweaver creates a Templates folder in your site root folder and saves your template in that folder. 

Template files have a .dwt file extension. 

To create an editable region: 

1. In the Layout category of the Insert panel, click Draw AP Div, and then drag on the page to create a new div 

to represent the editable region in the template. 

Note: You also click to indicate where to place the editable region, but using a div gives you more control over 

page layout. 

2. With the div still selected, do one of the following to create an editable region: 

• Select Insert > Template Objects > Editable Region. 

• Right-click (Windows) or Control-click (Mac OS) the region and select Templates > New Editable 

Region from the context menu. 

• In the Common category of the Insert panel, click the Templates button, and select Editable Region from 

the pop-up menu. 

• The New Editable Region dialog box opens. 

3. In the dialog box, enter a unique name for the region, and click OK. The editable region is within the selected 

div, and is enclosed in a light blue rectangle on the template. 

Note: You cannot use the same name for more than one editable region in a particular template. Use only letters 

and numbers in the name. 

4. Save and close the template. 

Editing a template 

You can edit a template at any time, even if you have created pages based on the template. 

To edit a template: 

1. Select Window > Assets. The Assets panel opens. 

2. Click the Templates button on the left side of the panel. A list of the templates for your site appears in the 

lower pane. The upper pane displays a preview of the selected template. (You may need to scroll the preview 

pane to see this.) 

3. Select the template you wish to edit and do one of the following: 

• Double-click the name of the template. 

• Click the Edit button at the bottom of the panel. 

4. Edit the template in the Document window, changing non-editable elements or creating editable regions in 

the template as desired. 

5. Save the edited template by choosing File > Save. The Update Template Files dialog box opens, with a list of 

the documents based on your template. 
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6. Click Update to update the documents based on the changes you made in your template. The Update Pages 

dialog box displays a summary of the updates performed. You may need to select Show log to view the Status 

information. 

7. Click Close. 

 

How to make websites accessible 

Creating accessible web pages has never been more important than today. With the adoption of accessibility 

standards in the United States, Canada, the European Union, Australia, Japan, and other countries, designers 

and developers need to ensure that people with disabilities can access the contents of websites and web 

applications, as well as the authoring tools used to create them. 

Accessibility refers to making websites and web products usable for people with visual, auditory, motor, and 

other disabilities. Examples of accessibility features for software products and websites include screen reader 

support, text equivalents for graphics, keyboard shortcuts, change of display colors to high contrast, and so on. 

Dreamweaver provides tools that make it accessible to use and tools that help you author accessible content. 

Dreamweaver enables designers and developers to create accessible pages that contain useful content for screen 

readers and comply with federal government guidelines. For example, dialog boxes prompt you to enter 

accessibility attributes—such as text equivalents for an image—when you insert page elements. Then, when the 

image appears on a page for a user with visual disabilities, the screen reader voices the description. 

No authoring tool can automate the development process. Designing accessible websites requires you to 

understand accessibility requirements and make ongoing decisions about how users with disabilities interact 

with web pages. The best way to ensure that a website is accessible is through deliberate planning, 

development, testing, and evaluation. 
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Accessibility preferences options 

To create accessible web pages, page elements need to be marked up with information for assistive technology, 

such as screen readers. For example, each image on a page should be given a text equivalent, called alternative 

text (alt text), that a screen reader voices to users in place of the image Designers often overlook accessibility 

features such as alt text when creating websites, but Dreamweaver CS6 enables you to set preferences that 

prompt you to provide accessibility information as you’re building the page. By activating options in the 

Preferences dialog box, you'll be prompted to provide accessibility-related information for form objects, frames, 

media, images, and tables as each element is inserted in a page. 

To set the accessibility preference, choose Edit > Preferences (Windows) or Dreamweaver > Preferences (Mac 

OS) and select the Accessibility category in the Preferences dialog box. 

 

Accessible templates 

Dreamweaver CS6 includes several templates designed for accessibility. These templates are visually balanced, 

as well as accessible to people with disabilities. They provide you with a fast and easy way to create exciting, 

engaging, and accessible content. 
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The W3C Web Accessibility Initiative has developed a quick reference list Web Content Accessibility 

Guidelines 2.0 requirements and techniques. 

1. Text Alternatives: Provide text alternatives for any non-text content so that it can be changed into other 

forms people need, such as large print, braille, speech, symbols or simpler language. 

2. Time-based Media: Provide alternatives for time-based media. 

3. Adaptable: Create content that can be presented in different ways (for example simpler layout) without 

losing information or structure. 

4. Distinguishable: Make it easier for users to see and hear content including separating foreground from 

background. 

5. Keyboard Accessible: Make all functionality available from a keyboard. 

6. Enough Time: Provide users enough time to read and use content. 

7. Seizures: Do not design content in a way that is known to cause seizures. 

8. Navigable: Provide ways to help users navigate, find content, and determine where they are. 

9. Readable: Make text content readable and understandable. 

10. Predictable: Make Web pages appear and operate in predictable ways. 

11. Input Assistance: Help users avoid and correct mistakes. 

12. Compatible: Maximize compatibility with current and future user agents, including assistive 

technologies. 

How to use the Adobe Dreamweaver Widget Browser 

A web widget is a web page component containing HTML, CSS, and JavaScript. Accordions, tabbed panels, 

and calendars are examples of web widgets. 

You can make your own selection of the web widgets available in Dreamweaver by using the Adobe Widget 

Browser. The Widget Browser is an AIR application that lets you browse, configure, and preview widgets, 

using a visual interface. 
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You can browse widgets on the Adobe Exchange by using the Adobe Widget Browser, but if you want to 

preview widgets, see details, or save widgets, you’ll need to create or sign in with an Adobe ID and password. 

When you open the Widget Browser, the application window displays the Adobe Exchange view by default. 

This view displays all of the widgets available on the Adobe Exchange—those created by Adobe as well as by 

third-party developers. Once you’ve saved a web widget, you can easily insert it into a web page. 

To insert a web widget into a Dreamweaver document: 

1. In Dreamweaver, click on the page in Design view where you want to insert a web widget. 

2. Select Insert > Widget. The Widget dialog box appears. 

3. Select the Spry Image Slideshow with Filmstrip (1.0), if not already selected. 

Note: Only the widgets you saved in the Adobe Widget Browser are listed in the Widget menu. You can also 

open the Widget Browser by using the link in the dialog box. 

 

4. Select the Blue option from the Preset menu. 

5. Click OK. The Spry Image Slideshow with Filmstrip is inserted into the document. 

6. In the Document toolbar, click the Live button. Viewing the Spry Image Slideshow in Live view allows you 

to preview and test the widget as it would appear in a web browser. 

 

7. Save the file. The Spry Image Slideshow with Filmstrip comes with a selection of preset images and text. 

You can customize the Spry Image Slideshow with Filmstrip widget by changing text, colors, and fonts and 

adding your own images. 

How to create interactive navigation 

There are several options for creating interactive navigation for your web pages: You can easily create: 

• Graphical buttons and navigation bars in Fireworks, and import them into Dreamweaver. 

• Image-based, or HTML, pop-up menus in Fireworks, and place them in a Dreamweaver file. 

• Rollover images that add visual interest and interaction by using Dreamweaver. 



www.eacademy.lk         www.eacademy.lk 

41 | P a g e  
www.eacademy.lk 

Advanced users may consider using Fireworks to create CSS-based interactive navigation. You can use the CSS 

Properties panel to extract complex CSS3 properties for buttons, such as text, border radius, and gradients. 

Select Edit > Insert > New Button. The button editor opens and the Properties panel displays button properties. 

 

Deselect the Enable option for 9-Slice Scaling Guides in the Properties panel. (To learn about 9-Slice Scaling 

Guides, select Help). Buttons contain four states: 

• Up (button untouched) 

• Over (pointer over button) 

• Down (button being clicked) 

• Over While Down (pointer over while button held down) 

You can view each state by selecting it in the State pop-up menu in the Properties panel. The current state of the 

new button is Up, as shown in the Properties panel. 

How to create pop-up menus 

Pop-up menus are menus that are displayed in a browser when a site visitor moves the pointer over or clicks a 

trigger image. Items in a pop-up menu can have URL links attached to them for navigation. 

You can use pop-up menus to display multiple links within a small space. They provide navigation flexibility 

without long download times. You can define the appearance of the pop-up menu so it matches the overall look 

and feel of your website. A pop-up menu is similar to a table: each menu item is like a table cell. You can 

customize the menu by choosing from a selection of font types, cell colors, and background image styles. 
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Editing a pop-up menu 

You edit a pop-up menu through the same context menu with which you created the pop-up menu. To edit a 

pop-up menu: 

1. To edit a pop-up menu, select the slice to which your menu is attached and double-click the pop-up menu’s 

blue outline in the workspace, or click the behavior handle and select Edit Pop-up Menu. The Pop-up Menu 

Editor opens. 

2. Set options in the Pop-up Menu Editor just as you did when you created your pop-up menu. 

 

How to add images 

Images are common elements of most websites. You add images by inserting them from an existing file. In this 

activity, you create a simple web page by adding an image to the page. 

Adding images 

Many different types of graphic file formats exist, but three graphic file formats are generally used in web pages 

GIF, JPEG, and PNG. GIF and JPEG file formats are the best supported and can be viewed by most browsers. 

When you insert an image into a Dreamweaver document, a reference to the image file is generated in the 

HTML source code. To ensure that this reference is correct, the image file must be in the current site. If it is not 

in the current site, Dreamweaver asks whether you want to copy the file into the site. 

After you insert an image, you can set image tag accessibility attributes that can be read by screen readers for 

visually impaired users. These attributes can be edited in HTML code. 

1. Select Insert > Image. The Select Image Source dialog box opens. 

2. Browse to the folder that contains the image you want to place in the document. 

3. Select the image. A preview of the image appears in the right side of the dialog box. 

4. Click OK 

Set image properties 

The Images Properties panel allows you to set properties for an image. If you do not see all of the image 

properties, click the expander arrow in the lower-right corner. 
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These are a few of the commonly-used image options you can set in the Properties panel: 

• W and H the width and height of the image, in pixels. Dreamweaver automatically updates these text boxes 

with the image’s original dimensions when you insert an image in a page. If you set W and H values that do not 

correspond to the actual width and height of the image, the image may not display properly in a browser. (To 

restore the original values, click the W and H text box labels, or the Reset image size button that appears to the 

right of the W and H text boxes in entering a new value.) 

• Src specifies the source file for the image. Click the folder icon to browse to the source file, or type the path. 

• Link specifies a hyperlink for the image. Drag the Point-To-File icon to a file in the Files panel, click the 

folder icon to browse to a document on your site, or manually type the URL. 

• Align an image and text on the same line. 

• Alt specifies alternative text that appears in place of the image for text-only browsers or for browsers that have 

been set to download images manually. For visually impaired users who use speech synthesizers with text-only 

browsers, the text is spoken out loud. In some browsers, this text also appears when the pointer is over the 

image. 

How to add rich media to a web page 

To add interest and interactivity, you can easily add rich media to web pages. Rich media includes most kinds 

of video, Flash videos, audio files, and interactive Flash content. 

 

Before you use Dreamweaver to insert content created with Adobe Flash, you should be familiar with the 

following file types: 

FLA file (.fla) the source file for any project, created in Flash. This file type can be opened only in Flash (not in 

Dreamweaver or in browsers). In Flash, you can publish a FLA file as a SWF file to use in browsers. 

SWF file (.swf) a compiled version of the FLA (.fla) file, optimized for viewing on the web. This file can be 

played back in browsers and previewed in Dreamweaver, but cannot be edited in Flash. 

FLV file (.flv) a video file that contains encoded audio and video data that can be played in Flash® Player. If 

you have a QuickTime or Windows Media video file, use an encoder such as Flash® Video Encoder or 

Sorensen Squeeze to convert the video file to an FLV file. 
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Adding FLV video to a web page 

You can easily add FLV video to your web pages without using the Flash authoring tool. You must have an 

encoded FLV file before you begin. Dreamweaver inserts a SWF component that displays the FLV file; when 

viewed in a browser, this component displays the selected FLV file, as well as a set of playback controls. You 

can also use Live view to provide a non-editable, more realistic rendering of how the page will appear in a 

browser. Live view does not replace the Preview In Browser command, but provides another way of seeing 

what your page looks like ―live,‖ without having to leave the Dreamweaver workspace. 

Select Insert > Media > FLV. 

 

Adding audio to a web page 

You can add sound to a web page. There are several different types of sound files and formats, including .wav, 

.midi, .mp3, and .ogg . Some factors to consider before deciding on a format and method for adding sound are 

its purpose, your audience, file size, sound quality, and differences in devices and web browsers. 

There are two methods for adding audio to a web page: Use a plug-in or encode your page using HTML5. 

When using a plug-in, remember that sound files can be handled differently and inconsistently by different 

browsers. 

For more information about common audio file formats along with some of the advantages and disadvantages of 

each for web design, see Dreamweaver Help, Audio File Formats. 

HTML5 provides additional flexibility for adding audio files to web pages without a plug-in. However, devices 

and web browsers must support the new standard for the audio to work properly. You use the <audio> element 

to embed an audio file on a web page. As with HTML5 video files, be sure to convert your audio files into three 

supported formats: .ogg, mp3, and .wav. These sources are listed in the <audio> tag, and the browser will use 

the first recognized format. 

1. In Design view, place the insertion point where you want to embed the file and select Insert > Media > 

Plugin. 

2. Browse for the audio file and click OK 

3. Save the file and Select File > Preview In Browser, and then select a browser to preview the audio in a web 

browser. 
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How to add text 

Adding text to a document 

To add text to a Dreamweaver document, you can type text directly in the Document window, or you can cut 

and paste text. You modify text by using the Properties panel. 

 

There are many additional options to working with text such as bulleted and numbered lists, adding special 

characters, and more. To learn more about adding text to a document, please see ―Working with text,‖ in 

Dreamweaver Help. 

Linking text to other pages and e-mail addresses 

After you’ve set up a Dreamweaver site to store your website documents and have created HTML pages, you’ll 

want to create connections from your documents to other documents. Before creating a link, make sure you 

understand how absolute, document-relative, and site root–relative paths work. You can create several types of 

links in a document: 

• A link to another document or to a file, such as a graphic, movie, PDF, or sound file. 

• A named anchor link, which jumps to a specific location in a document. 

• An e-mail link, which creates a new blank e-mail message with the recipient’s address already filled in. 

• Null and script links, which you use to attach behaviors to an object or to create a link that executes 

JavaScript code. 

In this section, you will use the Point-To-File icon to create a links to another page and the Properties panel 

Link boxto add a link to an e-mail address. Dreamweaver creates the links to other pages in your site using 

document-relative paths. For more information about links and other linking options, see the ―Linking and 

navigation‖ section of Dreamweaver Help. We will also look at linking in more depth in later activities. 
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How to create lists 

You can create numbered (ordered) lists, bulleted (unordered) lists, and definition lists from existing text or 

from new text as you type in the Document window. Definition lists do not use leading characters such as bullet 

points or numbers and are often used in glossaries or descriptions. Lists can also be nested. Nested lists are lists 

that contain other lists. For example, you might want an ordered or bulleted list nested within another numbered 

or unordered list. 

Creating lists 

In Adobe Dreamweaver CS6, you can easily create lists to organize information. You can use the Properties 

panel to set list style. To set the appearance of an entire list or for an individual list item, use the List Properties 

panel. You can set number style, reset numbering, or set bullet style options for individual list items or for the 

entire list. 

 

Place the insertion point where you want to add a list, then do one of the following: 

• In the HTML Properties panel, click either the Unordered List button or the Ordered List button. 

• Select Format > List and select the type of list desired—Unordered (bulleted) List, Ordered (numbered) List, 

or Definition List. The leading character for the specified list item appears in the Document window. 
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How to create data tables 

In Adobe Dreamweaver CS6, you can use tables to format data. Tables are a powerful tool for presenting 

tabular data. A table consists of one or more rows; each row consists of one or more cells. After you create a 

table, you can easily modify both its appearance and its structure. 

Although it is possible to use tables for page layout including text and images, this approach is now discouraged 

in favor of using CSS for layout. 

You can insert a new table from the Insert panel, or you can import a spreadsheet table created in a program 

such as Microsoft Excel. 

Inserting a table on a page 

You can insert a table anywhere on a page, including within another table. You can quickly insert a standard 

table with three rows and three columns, or you can modify options to insert a custom table. 

When you insert a table, a good idea is to set a header property for a row or column if you will use that row or 

column to provide labels for the information in the table. A header makes the table more accessible to people 

with visual impairments, because screen readers can recognize that a header contains labels. (Note that you 

must set a header row or column to provide such accessibility. It is not sufficient to use bold or centered text.) 

    

Modifying table properties 

You can modify the properties of a table, its rows and columns, or its cells by using the Properties panel. 

Attention to table borders and cell padding (the amount of spacing between table cells) in particular can help 

you create effective table designs. 
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You can also set a row or column as a header by using the Properties panel. Table cell headers help make tables 

more useful and accessible. 

 

How to create forms 

You can use forms to interact with or gather information from site visitors. With forms, visitors can provide 

feedback, sign a guest book, take a survey, or place an order for merchandise. In Adobe Dreamweaver CS6, you 

can create a variety of form elements, such as text fields, password fields, radio buttons, checkboxes, pop-up 

menus, and clickable images (such as a Submit button). 

The Forms category in the Insert panel contains buttons for creating forms and inserting form elements. 

 

 

To add a text field 

In the form Properties panel, select one of the three types of text fields: 

• Single Line text for short answers 

• Multi Line text for long answers such as the visitor’s description of a problem with a purchased item 

• Password text for passwords (in which asterisks appear in place of typed characters) 
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Using checkboxes and radio buttons 

Visitors click a checkbox or radio button to make a choice. With checkboxes, visitors can toggle a single option 

on or off, or they can select one or more options from a group of options. With radio buttons, visitors can select 

only one option from a group of options. 

• Click the Checkbox button in the Insert panel. 

 

• Click the Radio Group button in the Insert panel to insert a group. 

 

Using list menus and drop-down menus (List/Menu) 

Lists and menus allow visitors to select options from a list or pop-up menu. With a list menu, you can display 

multiple options in a confined space and allow visitors to select multiple items. Visitors can select only one item 

from a pop-up menu. 

• Click the List/Menu button. 

 

Using form buttons 

Form buttons control form operations. Use a form button to submit data entered into a form to the server or to 

reset the form. There are two types of form buttons: Standard text buttons are the browser's default button style, 

with text you want to display (Submit, Send, or Reset) graphical buttons use the graphic of your choice. 
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How to preview and test a web project 

Because you can't control which browsers or operating systems visitors will use to view your site, it is important 

to test your site in different browsers. Although you can do some of this on your computer by installing several 

browsers and running a local testing server, it can be a challenge to review all possible combinations of 

browsers and operating systems. For a detailed overview about the purposes of a testing server, see the 

Dreamweaver Developer Center article written by David Powers, Setting up a local testing server in 

Dreamweaver CS6 at www.adobe.com/devnet/dreamweaver/articles/setup_testing_server.html. 

Adobe BrowserLab is an online service that lets you test your website pages in a variety of web browsers and 

operating systems. For example, the following combinations of browsers and operating systems can produce 

slight differences in how your site appears: 

• Google Chrome 3.0 - Windows XP 

• Microsoft Internet Explorer 8.0 - Windows XP 

• Apple Safari 4.0 - Mac OS X 

• Mozilla Firefox 3.0 - Mac OS X 

The service works by taking screenshots of your web pages in different browsers and then displaying them on 

the BrowserLab page. BrowserLab is integrated with Dreamweaver CS6. You can test your pages from within 

Dreamweaver without publishing your pages to a server. 

 

http://www.adobe.com/devnet/dreamweaver/articles/setup_testing_server.html
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Using BrowserLab in Dreamweaver 

BrowserLab lets you preview local web content from within Dreamweaver, without requiring you to post it to a 

publicly-accessible server first. You can preview files from your local Dreamweaver site. 

1. Select View > Design. 

2. Choose Window > Extensions > Adobe BrowserLab. 

3. In the Adobe BrowserLab panel, choose Local/Network from the pop-up menu. 

How to publish web files 

Once you’ve specified a local site in Dreamweaver, you can specify a remote server for your site as well. The 

remote server (often referred to as the web server) is where you publish your site files so that people can view 

them online. 

The remote server is simply another computer like your local computer, with a collection of files and folders on 

it. You specify a folder for your site on the remote server, just as you specified a folder for your local site on 

your local computer. Dreamweaver refers to the specified remote folder as your remote site. 

 

When you set up a remote folder, you select a connection method for Dreamweaver to upload files to your web 

server and download files from your web server. The most typical connection method is FTP, but Dreamweaver 

also supports local/network, FTPS, SFTP, WebDav, and RDS connection methods. 

Connecting to a remote site 

Many websites let you publish files through FTP (File Transfer Protocol). You connect to a remote site by using 

the Site Definition dialog box in Adobe Dreamweaver CS6. 

1. Select Site > Manage Sites. 

2. Double-click the name of the site you want to connect remotely. 

3. Click the Servers category in the left column. 
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Once you establish an FTP connection, you can use the Get and Put commands to transfer files from the Files 

panel. 

 

When you transfer a document between a local and remote folder using the Files panel, you have the option of 

transferring the document’s dependent files. Dependent files are images, external style sheets, and other files 

referenced in your document that a browser loads when it loads the document. 

To upload the entire site for the first time: 

1. In the Files panel (Window > Files), select the files to upload. 

2. Click the Expand/Collapse button in the Files panel toolbar. The Files panel expands. 

3. Click the Connects To Remote Host button in the Files panel toolbar. Dreamweaver connects to the web 

server. 

4. Select the root folder for your site in the Local (right) pane. 

5. Click the Put Files button in the Files panel toolbar. 

6. You may be presented with a dialog box asking if you wish to put the entire site. Click OK. Dreamweaver 

uploads the site’s files and opens the Background File Activity dialog box. 

 


